Support Center

I am using Firefox and getting a message that I need a plug-in.

Last Updated: Sep 15, 2015 04:58PM EDT
When using the Firefox browser, you will need to install Silverlight. You can download here: http://www.microsoft.com/silverlight/
If you are still receiving this message, the installation may not have completed. Please try restarting your computer.

Contact Us

support@tribecashortlist.com
http://assets0.desk.com/
false
desk
Loading
seconds ago
a minute ago
minutes ago
an hour ago
hours ago
a day ago
days ago
about
false
Invalid characters found
/customer/en/portal/articles/autocomplete